Shaderlight

How do you light an exterior through a window ?

 
chrislbj
Total Posts: 5

Hello. Please can you help me to light an exterior view through some glass doors?

I have attached 4 images to show what i have tried :-

1 - the glass in the doors is coloured white and then set to transparent thin glass. this get good relectons but no view though, and also other white items in the model and effected by the transparency setting in the materials editor. I can’t seem to get the same colour ( ie white ) to have differnt settings throughtout the model ( the 2 baby highchairs should be white )

2 - Now i changed the glass panels to ’ translucent glass grey ’ instead of white. This stops the baby high chairs from changing , but there is still no view through the window

I then tried adding skylight portals to the glass but this seems to make no difference either

3 - Then i tried building walls around my exteior scene and adding in some area light to try and light it independently but this didnt seem to make much difference either

4 - Finally i removed the glass panels all together. Now you can see the exteior but obviously there are no refections as there is no glass

I’m hoping I’m missing something simple but dont know what else to try

At the moment my render settings are Global Illuminations / Artificial Lights Only and Sketchup Background , although i have also tried with a Custom background including the sky jpeg which is being used in the model

Thanks

Chris

Image Attachments
1.png2.png3.png4.png
Click thumbnail to see full-size image
kfoojones
Total Posts: 286

Hello Chris,

It looks like the first image was using the same white material for the glass and various white objects, such as the baby chairs etc. It should be possible to create a new white material which is just used for the glass, leaving the other white material with a non-glass material type for the other objects.

In order for the outside to be visible through the glass, it will need to be lit. This is usually done by the skylight, but when you choose ‘Artificial Lights Only’, the skylight is disabled. This means that there is very little light reaching the outside areas, when it should be illuminated many times more brightly than the artificial lights inside. I would try using the ‘Physical Sky’ or one of the ‘Preset’ or ‘Moofe’ lighting environments. Note that this will probably make the outside overexposed compared to the inside, which, although physically accurate, may not be exactly what you intended. You can either render twice at two different exposures and then combine the two images as a photographer would when creating an ‘HDR’ image, or you can try increasing the intensity of your interior lighting to bring it up to the level of the skylight. Note that in the latter case, you will need to use unrealistic intensity levels for your interior lighting for it to compete with the sun.

I also recommend that you use your sky image as the custom background (under Shaderlight’s Render Settings), rather than apply it to a ‘billboard’, as that will enable you to control its brightness directly and prevent it looking like a poster stuck into the scene.

I hope that helps, but please do let us know if you need any further assistance.

Shaderlight support

EGIE
Total Posts: 509

And by the way - this is a very nice scene! - Made with quality and made with a believable amount of decoration.
thumbs up !  :-)

chrislbj
Total Posts: 5

Hello and thanks for the advice….

I’ve been trying out your suggestions but am getting much poorer results :-

I switched off ’ artifical lights only ’ and tried various other settings….

a - was with a physical sky background
b - with a london morning preset
c - with a moofe environment

i also took my sky image off the billboard and included it as a custom background but it now doesnt show up at all ? How do you make it appear ?

Also i have again tried to add a different white surface as ’ transparent glass ’ into the doors and as you can see in picure ‘d’ it still changes various other surfaces around the model too ( which aren’t rendered using the same white )

Any more help wouls be great thanks

Chris

Image Attachments
a.pngb.pngc.pngd.png
Click thumbnail to see full-size image
kfoojones
Total Posts: 286

Now that the skylight is a major light source in the room, it is necessary to use Skylight Portal lights over the windows, so that the renderer can efficiently find rays that reach the sun/sky. Please see this tutorial for details on how to create portal lights. There is currently a bug that means portals placed exactly on another surface (such as the glass) can sometimes introduce undesirable noise in the render. To prevent this, move the portal light away from the glass surface by a millimetre or so.

Have you tried adjusting the background brightness setting in the Shaderlight Render Settings window? It could be that it is appearing white due to overexposure.

To introduce a different white surface into the model, you can right-click (or control/two-finger-click on macOS) on the existing white material and choose ‘Duplicate’ from the drop-down menu. It seems that, in SketchUp 2017, if the two materials have exactly the same colour and opacity it will only actually use the first one. However, if you make the one you intend to use as glass partially transparent, you can successfully apply it to objects in your model. Doing so may also make things clearer in the SketchUp window. (Note that the opacity setting on the SketchUp material doesn’t affect the opacity of Shaderlight’s ‘Transparent’ materials, because they use a different, physically based, method for computing transparency.)

Regards,
Shaderlight support