Shaderlight

Shaderlight not rendering at all

 
yrwong5
Total Posts: 3

Hi have SU 2018 and Shaderlight 2018.  I use Windows 10 and I have an Alienware laptop.  I have an entire home and landscape project and the file size in SU is approx 500,000 kb.  I need to be able to render my projects for my clients.  Shaderlight is not working at all.  It continually freezes and I have to restart SU in order to get out of Shaderlight.  The programming shows massive projects being rendered on your website.  Can you explain what is wrong.

kfoojones
Total Posts: 286

Hello,

I think that 500MB is quite large for a SketchUp file, so you may be getting close to the limit. The first thing is to check that you’re not running out of memory – you can use Task Manager or Resource Manager to monitor your computer’s memory usage during and after a Shaderlight export. If it runs low and your computer starts using virtual memory, performance will suffer greatly.

Do you know whether the file is that large mostly due to massive amounts of geometry, or lots of large texture maps? I’m afraid you will probably need to optimise some aspect of the model to get it to render efficiently – reducing geometry detail in areas far from the camera (or deleting it altogether if it isn’t visible from the camera); reducing texture resolution for surfaces far from the camera.

If you can share your SketchUp file with us at Shaderlight, we can take a look and offer more specific suggestions. If you would like to do that, please send us a Dropbox or similar link to support@artvps.com.

Regards,
Shaderlight support

yrwong5
Total Posts: 3

Thank you.  I will be more than happy for any help at all.  My clients really want the full renderings.  I will send you the file.

kfoojones
Total Posts: 286

Hello,

Thank you for sending your model to us. We have tried it here and were able to export and render to completion, so there may be something specific to your set-up that is causing a problem.

On our machine, SketchUp and Shaderlight between them used over 7.5GB of memory during the export process, so if your machine has less than, say, 12GB of memory, it may be running low (accounting for the operating system and any other running processes). Once the physical RAM is exhausted, the export will slow to a crawl. (The machine we used has 16GB of RAM.)

The export itself took 6-7 minutes on our machine, during which time SketchUp is unresponsive (in order to prevent inconsistencies in the exported data), and the Shaderlight window won’t show any rendering, so some patience is required. The render itself only took half a minute, using the settings saved in the model you sent.

If you’ve checked that the memory consumption on your machine is within its limits, and your renders are taking more than 10-15 minutes to start, let us know and we’ll look into other ways of diagnosing the problem you’re experiencing.

Something that might help you produce renders more quickly with limited resources is hiding bits of the model that aren’t visible from the that viewpoint (and don’t cast shadows into the visible area) – e.g. other rooms in the building, besides the room of interest and the adjoining rooms; the planting outside the building when doing an interior render, besides any plants visible through windows, or that might cast shadows through the windows.

Regards,
Shaderlight support

yrwong5
Total Posts: 3

Thank you.  I will try again this weekend.  I also contact Microsoft and found that there January 3rd windows update changed my graphics card from the NVIDIA GeForce to Intel which was a huge problem.  They fixed that for me, so hopefully that was a large part of the problem.  Thanks again.