Shaderlight

Background Objects Projected on Windows

 
QStuff
Total Posts: 54

See the accompanying images.  One is a snip taking of part of a scene in Sketchup and the other is the result of rendering the same scene.  Note that the columns and arches in the background are projected onto the two side windows but show as they should on the center window. All three windows are derived from the same component with different size parameters.  The skylight portals were added after the windows.

I would be happy to provide the entire model; however, it is very large.

Image Attachments
SL_Render.PNGSL_Model.PNG
Click thumbnail to see full-size image
kfoojones
Total Posts: 286

Hello QStuff,

From the renders, this looks like it could be a refraction issue. Are the materials the same on all three windows and are all three modelled with the same number of faces?

If the two side windows are using a ‘solid glass’ material but only have a single face, light passing through will be excessively bent, resulting in objects behind the glass appearing in the wrong place.

You can either use a ‘thin glass’ material or use two faces, spaced apart by the desired thickness of the glass. The latter is more physically correct, as it will model the small amount of refraction that occurs as light passes through the pane of glass, while the former is simpler to model, slightly faster to render and the missing refraction will be barely noticeable in most cases.

If neither of those two suggestions helps, please do share the model (or a cutdown version) with us at support@artvps.com.

Regards,
Shaderlight support

QStuff
Total Posts: 54

The glass material is the same in all three windows and is a single surface.  The selected glass material is Sketchup’s Translucent Glass Gray and I left the Shaderlight material type Auto, which works fine everywhere else (including the center window). I rendered the scene again, but this time I edited ShaderLight material and set it to Transparent, Thin Glass. That seems to have corrected the problem.

Thanks. I really think auto should have been the correct setting given the material is glass and only one surface.

kfoojones
Total Posts: 286

Hi,

Glad to hear that it’s working now.

The thing about the default behaviour for the auto setting is that Shaderlight can’t tell whether the glass is only one surface or not – that is something only the user can know. We chose to default the ‘auto’ materials to behave as ‘solid’ glass in the interests of behaving correctly for fully-modelled glass objects, but realise that won’t suit all users all the time.

Regards,
Shaderlight support