Shaderlight

Grainy Render Problems

 
Harry96
Total Posts: 2

Can someone help me on this please…

See attached image I have rendered useing 1080p resolution and maximum render quality.  Yet in some areas it’s quite grainy - particularly at the top of the window.

Any ideas how I can overcome this?

Thanks!

Image Attachments
KuroLok_RL_in_lounge_area.jpg
Click thumbnail to see full-size image
kfoojones
Total Posts: 286

Hello,

I’m not sure what the source of that noise might be from the render alone. If you’re able to share your model with us (perhaps via a Dropbox, or similar service, link to support@artvps.com) we can take a look at it here and see if we can locate the source.

If you’re not able to share the model, a screenshot or two of the SketchUp viewport showing the positioning of the various light sources might offer a clue.

Regards,
Shaderlight support

Harry96
Total Posts: 2

Thanks - I’ve just sent a link to you.

awaddington
Total Posts: 394

Further, to that….please provide the settings for your artificial light sources.

How tall is the shaft for the skylight?  Is the panel in the ceiling retractable? I ask because maybe the light is bouncing around above that panel and by the time it comes through the opening the rays are reduced. That would reduce the number of samples processed in the visible scene and potentially cause some of the speckling if the engine is confused about how much light should be hitting the surface (kfoojones may correct me on that technical point). Any light coming in from that skylight is coming downward and reflection paths to the window wall may be blocked by the dark carpet and the sofa, further reducing the sample that hits the wall.  Maybe a second portal on the skylight opening into the actual room or moving that portal to the opening to the room would help?

The lights around the walls look pretty washed out suggesting they are either too strong for the scene or not enough light is in the scene and you are forced to overexpose the scene to get the current exposure.  It’s also curious that the lights along the window wall are not casting the same patterns on the wall as those along the right-hand wall, suggesting that they may have a different intensity. The light sources look like they may not be positioned under the fixture geometry but that is hard to tell from the render. It also appears that you use different sources for some of the lights (at least one ies and the rest appear to be point lights. Maybe try all .ies lights for consistency and to avoid some of the “burn” along the wall. You may also add some color to the light sources and this will help reduce some of the glare, helping you balance your scene Assuming you want a relatively cool light, you might try an RGB value of [212,235,255] or [244,255,250]. If you want something warmer, try [255,244,229]. If you haven’t already, I recommend making a component for your potlight source and copying—that will allow you to experiment with settings, by changing them only once (instead of once for every bulb)

Are similar lights positioned on the walls behind the camera?

Most of the lights in the scene appear to point up or down, do direct lighting may be limited along the top of the wall.  The same issue may be occurring on the other wall, but is masked by the point light “burn”. If this issue prevents you from getting the results you desire, you may consider adding some “side-ways” light with area lights, similar to how a photographer would use a flash.  I would try to fix this through light sources and settings first though, as that will provide a more realistic render in the end.

In short, this is an attractive scene and I see no reason that the issues you see cannot be addressed. We just need more information. Any additional information you can provide is helpful.

Cheers,

Andrew  

(PS—as an unsolicited side note, there is a scale issue with your end tables, more specifically the wine bottles, that may detract from the realism of your scene. a standard wine bottle is 12 inches/305mm tall)

kfoojones
Total Posts: 286

Hello,

Thank you for sending your model over.

Having experimented with a few things, here are some suggestions for things that should help with the noise:

1) The main source of noise is the large area light in the ceiling. Due to the way area lights are sampled, surfaces near the plane of the light (i.e. the tops of the walls near the ceiling, in this case) can receive quite a lot of noise. This area light is not contributing a huge amount of light to the image and doesn’t correspond to a real-world light source, so it would probably be best just to delete it and rely on the other light sources.

2) The walls behind and to the left of camera are missing, which means that a fair amount of reflected light is escaping from the model and not contributing to the render. Fully enclosing the room should smooth out the illumination a bit, which might be particularly desirable if you remove the large ceiling area light (whose main contribution was to evening out the light, rather than overall brightness, per se). The missing wall ‘behind’ the camera is actually slightly in front of it, so you’ll need to either move the camera forward and increase its field of view (which will alter the perspective distortion), or use a section plane so that the camera can see through it.

3) As Andrew alludes to, continuing the recessed down-lights all the way around the room will add more indirect illumination, helping to replace the light lost by deleting the area light.

4) The reason the lights along the window wall look different to the ones along the right-hand wall (as pointed out by Andrew) is that the ones on the right-hand side are actually much closer to the wall – the perspective of the viewpoint hides just how much. The single light along the right-hand wall that looks different is due to it being slightly higher up in its recess than the others, meaning that the edge of the recess casts more of a shadow.

5) The model as we received it is set up with a ‘custom’ lighting environment type, but with no image specified. This will result in a black lighting environment, which is effectively the same as ‘artificial lights only’. This would be consistent with your lighting setup, which uses area lights over the windows, simulating skylight, but I thought I would just check that the model is the same for us as it is for you. Switching the lighting environment to ‘artificial lights only’ to ensure Shaderlight won’t waste time processing a completely black skylight might make the renders a bit faster.

6) Because the light source is an area light and not a portal light, I don’t think it would be worth adding a second area light in the lower opening of the skylight. Portal lights have special behaviour to avoid double-counting light if it passes through two portals, but area lights don’t have that, so balancing the light inside the skylight shaft and the light being emitted into the room from it would be tricky (technically, it would be impossible to get physically correct). Luckily, the global illumination seems to be handling this opening reasonably well and I don’t think it’s a significant source of noise.

7) A little thing that would remove some localised noise is turning the TV screen into a normal face (by ‘exploding’ the image entity in SketchUp) and then assigning a self-illuminating Shaderlight material type to it. This would remove the need for the area light pointing at the screen, which is producing a subtle but incorrect and noisy extra shadow of the TV on the wall.

8) Finally, there is another area light on the ground outside the room, pointing up. This contributes a little light to the render (through the missing wall to the left of camera), but it isn’t very much and again doesn’t correspond to a real-world light source, so I would recommend removing it – especially if you add the missing walls.

I hope that is of some help,
Shaderlight support