Shaderlight

Transparency not rendering

 
cmccarty
Total Posts: 1

I cannot get the transparent water in Sketchup to show up as transparent in the rendering. I have tried making one side transparent, the other side transparent, and both sides transparent in sketchup but it just doesn’t transfer over to Shaderlight. Any tips?

awaddington
Total Posts: 394

Can you provide some more details?

- which water material are you using
- what material settings are you using? Including
—- Sketchup opacity/transparency setting for the material
—- Shaderlight material settings
- screenshot of the model showing all settings and light source
- screenshot of the render

I’m sure the answer is simple we just need a bit more information.

Cheers,
Andrew

QStuff
Total Posts: 54

I am having the same problem with glass. It rendered fine before the update, now it’s solid white. The Shaderlight material is set up as transparent, thin glass.  I made NO change to the model.

kfoojones
Total Posts: 286

Hello QStuff,

Are you able to provide more detail – similar to what awaddington requested above? In particular, the SketchUp material’s colour and opacity setting and screenshots of the model set-up and resulting render?

Many thanks,
Shaderlight support

awaddington
Total Posts: 394

QStuff…what happens when you change the material transparency in Sketchup (not the Shaderlight settings, but the SU material?

Can you post images?

QStuff
Total Posts: 54

This is what I have.  There are light portals over the glass if that means anything.

Image Attachments
SL62.PNG
Click thumbnail to see full-size image
awaddington
Total Posts: 394

Try reducing the opacity?  I’m not sure if that affects the thin glass setting but I know it will affect solid glass…maybe that’s related?

QStuff
Total Posts: 54

It has always worked before, but I’ll try it anyway.

Also, I now get a lot of flickering whilethe SL material editor is open.

awaddington
Total Posts: 394

What version did it last perform as expected? 

If it was 6.0.0 or 6.1.0 then my suggestion likely isn’t the problem, I don’t think the transparency feature was touched in 6.2.0—I’ll leave you in Kfoojones’ capable hands. smile

Good luck

kfoojones
Total Posts: 286

The thin glass material ignores the opacity setting, so that shouldn’t make any difference to the render.

It does have a combination of transmittance and reflectance, though, so you might be seeing reflections overwhelming anything on the other side of the glass, if the objects behind the glass are dark compared to those on the camera side.

Another possibility is that you are getting interference between the glass and the light portals – if they are in exactly the same place then rays can intersect them in random order, resulting in rendering artefacts (usually noise, but maybe unexpected tinting). Moving the portals a few millimetres off the surface of the glass should fix the problem in that case.

Which update are you referring to? The 6.2.0 release issued this week shouldn’t have changed the behaviour of transparent materials, which we last touched in the 6.0 major release.

We did make some changes to the material editor UI (to address a crash on some systems), so we might have inadvertently introduced the flickering. Where exactly does the flickering occur?

Regards,
Shaderlight support

QStuff
Total Posts: 54

First, I tried setting Opacity to 11 then 0.  Neither one changed anything.

Second, I always install your updates regardless of how trivial the change may be.  So, I did update from 6.1 and produced renderings of this model using it.  I believe there was a similar problem when I first installed 6.1 where SL did not recognize Sketchup’s glass without setting the SL material to think glass.

As I was typing I just noticed something while rendering the model again.  You will see the windows are solid white except on the far right, under the semitransparent curtains. You can see the image outside the room through the glass there.

Image Attachments
SL_62a.PNG
Click thumbnail to see full-size image
awaddington
Total Posts: 394

Hi QStuff—could this be an issue with the light settings? Specifically the skylight portals?  It looks like they are blown out (see where the right-hand current blocks light and shows the exterior).  Or as SL Support mentions, it could potentially be a reflection. Another thought…check the settings for the panes behind the right curtains and see if they are diffeerent from the other panes of glass.

kfoojones
Total Posts: 286

You can also see a very faint hint of greenery in the middle of the window, suggesting that this is due to overexposure of the exterior. The curtains on the right might be adding just enough tint to bring the brightness of the exterior down to the visible range, although it’s not clear why the left-hand curtains aren’t having the same effect.

Although the opacity setting is ignored for thin glass, the colour itself will affect the amount of tinting – making it a darker shade of grey will make it more tinted and reduce the brightness of the exterior. If your portals are exactly on top of the glass, though, rays might be ‘teleporting’ through the glass, making the tint ineffective. In this case, move the portals a few millimetres away from the glass faces.

Another option might be to lower the background brightness setting in Shaderlight’s Render Settings dialog.

I’m not sure why the render would have changed between 6.1 and 6.2, though.

Regards,
Shaderlight support

QStuff
Total Posts: 54

OK. I think I know what happened.  First, the image outside the window is not a background image file—it is a rectangular surface with a texture on it.  It’s placed about 10’ beyond the window.  Apparently your update majorly changed how the outside is lighting is applied.  The texture was completely washed out which made it look like the glass was white and why some hint of the texture appeared at the edge of the window.  I removed the rectangle and added a background image. 


This particular scene is something I use to test various lighting techniques.  I hope this change hasn’t caused me too much work in other models that I have not yet tested.

kfoojones
Total Posts: 286

Hi QStuff,

Are you able to share your model with us? We are keen to work out what happened to make the lighting change. If you can, please email it (or a Dropbox or similar link) to support@artvps.com.

Many thanks,
Shaderlight support

QStuff
Total Posts: 54

I would love to send it to you but a miracle has occurred. After putting it back the way it was I can’t make it happen anymore. I’ve tested a few other models and I can’t see any difference between 6.1 and 6.2. I’ve been using the position rotation slider for years. I didn’t see much need for a numeric entry. I guess it was much of an update.smile