Shaderlight

SL Material Editor vs. SK Material Editor

 
togo
Total Posts: 15

Hi,

so far I have always used the “auto” setting in the SL Material Editor. But now there is a mirror in the scene and I would like it to reflect what is in front of it. But I see no difference between the “auto” setting in the SL Material Editor and changing the material finishes to Type: Glossy and Finish: Mirror. The mirror receives shadows, though in the SK element infos it is set to receive and cast no shadows and it does not reflect the room nor the objects right in front of it. What do I do wrong? Can someone give me a hint?

Also, often I change the Material setting of one material in the SL Material editor – f.i. from dull to shiny, other materials on other objects are changed as well.

It seems like I do not really know how to handle the SL Material Editor in combination with the SK Editor.

Thanks for help.
*T

awaddington
Total Posts: 388

Hi T,

Can you post a render image of the material that’s causing the problem, and provide more information about the settings you used?

This sort of problem usually has a really simple solution.

Is it possible that you have two faces occupying the same space or that the material is on the wrong side of the face?

Cheers

togo
Total Posts: 15

Hi awaddington,
thanks. I reversed the faces now back and forth and replaced the mirror, but it is still the same.
Here’s a screenshot with the settings. The scene is just a test-scene with some warehouse objects.
Thanks*togo

Image Attachments
Bildschirmfoto_2019-03-17_um_10.55_.03_.png
Click thumbnail to see full-size image
togo
Total Posts: 15

... I tried some more: here are 2 screenshots with 1. SL Material Editor for the mirror set to Auto and 2. set to Glossy and Mirror. This way it seems to get better. The mirror still receives shadows though and the mirror is rather blurry.
(wrong order of the images)

Image Attachments
Bildschirmfoto_2019-03-17_um_12.22_.16_.pngBildschirmfoto_2019-03-17_um_12.18_.17_.png
Click thumbnail to see full-size image
awaddington
Total Posts: 388

Hi Togo

Try using they shiny mirror settin instead of the glossy setting.

I think that may be the issue.

Andrew

togo
Total Posts: 15
awaddington - Mar 17, 2019 03:51pm

... I think that may be the issue.
Andrew

It is! So for mirror never auto or glossy but necessarily shiny type. Thanks.
*T

Image Attachments
Bildschirmfoto_2019-03-17_um_18.27_.56_.png
Click thumbnail to see full-size image
awaddington
Total Posts: 388

Great!

Beautiful scene by the way.  Nice work.