Shaderlight

Specks of light when rendering interior

 
JohanMatheson
Total Posts: 1

Hello all,

When rendering an interior scene, I always end up with lots of specks of light where the sunlight hits an interior surface (in this case, the floor). I’ve attached a quick example. Settings used: quality level 10, Global Illumination, no auto exposure (exposure is at 0) and I’ve (of course) used skylight portals (on the outside of the window).
(The model is a simple example of the issue, but I’m working on a much larger model of a room where the issue is really distracting—I’ve attached an image of that room as well).

When I remove the skylight portal, the render becomes “grainy” but at least the sunlight hits the floor in a more realistic manner.

What am I doing wrong? Any suggestions?

Thanks in advance,
Timothy

 

Image Attachments
Stift_124_voor_Shaderlight.jpgStift_124_voor_Shaderlight_SU.jpgStift_124_voor_Shaderlight_no_portal.jpgStift_120.jpg
Click thumbnail to see full-size image
kfoojones
Total Posts: 275

Hello Timothy,

Is it possible that your skylight portals are touching the window panes? If so, try moving the portals a millimetre or so away from the glass to see if that improves the results – there is an issue when two surfaces are in precisely the same place because it is essentially random which one the rays will hit first.

If that doesn’t help in your case, are you able to share your test model? You could either post a Dropbox (or similar) link here, or email it to us at support@artvps.com.

Regards,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - May 08, 2019 02:29pm

Hello Timothy,

Is it possible that your skylight portals are touching the window panes? If so, try moving the portals a millimetre or so away from the glass to see if that improves the results – there is an issue when two surfaces are in precisely the same place because it is essentially random which one the rays will hit first.

If that doesn’t help in your case, are you able to share your test model? You could either post a Dropbox (or similar) link here, or email it to us at support@artvps.com.

Regards,
Shaderlight support

I’m having a similar problem with white specs/noise on an interior.  Even as a high quality HD render.  When the light portals are place automatically (by hovering over the window glass rectangle, having the tool “highlight” in turquoise or light blue, and then accepting…) in that situation, is the tool automatically placing the portal directly against the glass plane without any distance?  Screenshot of rendering in progress (tiled) and the model shot with my settings.

 

Image Attachments
render_03-002.jpgrender_model_shot-02-003_settings.jpg
Click thumbnail to see full-size image
kfoojones
Total Posts: 275

Hi,

Yes, when you create a portal (without using the control (Windows) or alt/option (macOS) key to delete the template face), the portal will be placed in exactly the same place as the existing face. You will then need to move it very slightly in one direction or the other. The best direction might be affected by the construction of your window frames – ideally, you want the portal to remain enclosed by the window frame so that there are no gaps that light could ‘leak’ through, which could cause noisier results.

Regards,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - Feb 27, 2020 08:15pm

Hi,

Yes, when you create a portal (without using the control (Windows) or alt/option (macOS) key to delete the template face), the portal will be placed in exactly the same place as the existing face. You will then need to move it very slightly in one direction or the other. The best direction might be affected by the construction of your window frames – ideally, you want the portal to remain enclosed by the window frame so that there are no gaps that light could ‘leak’ through, which could cause noisier results.

Regards,
Shaderlight support

Ah…so when using the auto placement, where it senses the plane of glass and places the portal…the portals is exactly on the glass.
Unless you use CTRL?
And if you manually create the rectangle for the portal, same thing?  Exactly on the glass?

kfoojones
Total Posts: 275

Hi,

Sorry, I was a little unclear – using the control/alt/option key will simply delete the face that you click on, so there will obviously be no issue with the portal being in the same place. When using your window glass as a template, you clearly won’t want to use control to delete the glass, hence the need to move the portal after creating it. Another approach would be to create a sacrificial template face on the inside or outside edge of the window frame (assuming that is away from your glass) and then use the control-key creation method to delete the template face as you create the portal. The results should be the same in either case, so use whichever method is easiest for you.

Perhaps another way of putting it is that there aren’t really ‘auto’ and ‘manual’ placement methods – Shaderlight will simply use whatever SketchUp face you click on as a template to create the portal. Sometimes it is convenient to use an already existing glass face to create a portal of the correct shape and sometimes it is more convenient to create a special template face to define the shape of the portal and then use the control-key to remove the template face when creating the portal.

Regards,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - Feb 27, 2020 08:40pm

Hi,

Sorry, I was a little unclear – using the control/alt/option key will simply delete the face that you click on, so there will obviously be no issue with the portal being in the same place. When using your window glass as a template, you clearly won’t want to use control to delete the glass, hence the need to move the portal after creating it. Another approach would be to create a sacrificial template face on the inside or outside edge of the window frame (assuming that is away from your glass) and then use the control-key creation method to delete the template face as you create the portal. The results should be the same in either case, so use whichever method is easiest for you.

Perhaps another way of putting it is that there aren’t really ‘auto’ and ‘manual’ placement methods – Shaderlight will simply use whatever SketchUp face you click on as a template to create the portal. Sometimes it is convenient to use an already existing glass face to create a portal of the correct shape and sometimes it is more convenient to create a special template face to define the shape of the portal and then use the control-key to remove the template face when creating the portal.

Regards,
Shaderlight support

Excellent. Again, thanks for the clarification.

blackdogsketch
Total Posts: 23

I also discovered some open holes in a far end of my model so I’ve now fixed those.  We’ll see how things roll now.

kfoojones
Total Posts: 275

Great – we’d be interested to see and hear how you get on.

A couple of other things might be of help in the future:

1) Quality level 10 traces substantially more rays than level 9 and is intended to help in pathological cases where Shaderlight is struggling to find a noise-free solution. In almost all cases where the model is well built, the lighting is within realistic ranges and there aren’t too many ‘glossy’ materials, quality 9 will produce virtually indistinguishable renders from quality 10 in noticeably less time. (Having said that, if I’m leaving something to render overnight anyway, I will probably just set it to quality 10 to make sure…)

2) With experience, you can usually make a good guess about whether a final quality 9/10 render is likely to be noise free by rendering at lower resolution and at quality 5. Whilst there are certainly cases that can catch you out, I find it’s quickest to do quick trial renders at, say, 720x405 Q5 while tweaking the lighting and materials to get a reasonably smooth render before committing to a final, full resolution and quality render.

Regards,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - Feb 27, 2020 10:18pm

Great – we’d be interested to see and hear how you get on.

A couple of other things might be of help in the future:

1) Quality level 10 traces substantially more rays than level 9 and is intended to help in pathological cases where Shaderlight is struggling to find a noise-free solution. In almost all cases where the model is well built, the lighting is within realistic ranges and there aren’t too many ‘glossy’ materials, quality 9 will produce virtually indistinguishable renders from quality 10 in noticeably less time. (Having said that, if I’m leaving something to render overnight anyway, I will probably just set it to quality 10 to make sure…)

2) With experience, you can usually make a good guess about whether a final quality 9/10 render is likely to be noise free by rendering at lower resolution and at quality 5. Whilst there are certainly cases that can catch you out, I find it’s quickest to do quick trial renders at, say, 720x405 Q5 while tweaking the lighting and materials to get a reasonably smooth render before committing to a final, full resolution and quality render.

Regards,
Shaderlight support

Thanks!  I have discovered exactly that…render for effect at 720x405 and Q5.
I had noise at that level, so as you said, since I was rendering overnight, I went up to 2400 x1080 Q10.  I still have much much more noise than I should.  I ahve repaired all holes in the model…window frames are well-cnsturcted, exactl;y like 3 D Storefront…single panes of glass…sketchup meteriality at no color, full transparent.  I pulled all the skylight portals away from the glass plane by 1/16”.  Not great results.

Another thing I am wondering about is the balance between interior and exterior.  I wasnted the light of the sketchup Physical Sky, late inthe day.  But the exterior is WAY too bright, and Im not sure how to balance that out.  Auto Exposure should do that?
I’m also not getting the warm color of the physical sky at this time of day.

Again, I sincerely appreciate the timely help!  Just upgraded to 2020 and thought maybe the upgrade would produce higher resolution results.  I’m attaching a screenshot of the rendering with the Settings dialog box at the left.

Image Attachments
render_model_shot_highest_res_HD-03-004_settings.jpg
Click thumbnail to see full-size image
blackdogsketch
Total Posts: 23

Hmmmm….found some more exterior glazing at the far end of my model. will seal that up with portals and see what the render looks like Monday AM.

kfoojones
Total Posts: 275

I notice that you have your background set to ‘SketchUp Background’. I think using the ‘Lighting Environment’ setting should produce better results – this will render the background consistently with the lighting coming from the physical sky, which should include the warmer colour of evening sky light. The ‘SketchUp Background’ setting will render the exterior of your scene similarly to SketchUp’s viewport (and controlled by your SketchUp Style settings), which is not a physically realistic appearance. For example, if your SketchUp background is set to white, then it will appear white in Shaderlight too (modulo your exposure setting and any tinting on the windows).

While testing this today, I found that using SketchUp Background produced unexpectedly dark views of the exterior (even using a pure white, transparent material), similar to your original render in your other thread. There may be a bug in the current version of Shaderlight, or maybe I set my scene up incorrectly – I’ll need to investigate further. In any case, for photorealistic results, I would prefer the Lighting Environment setting (or a photographic backplate).

Note that the visibility of the sky lighting will depend on the brightness of your interior lighting. It looks like most of the lighting in your scene might be coming from the interior light sources, in which case the sky light will be fairly subtle.

If you would like us to take a closer look, you could send your model (or a Dropbox or similar link, if it’s large) to support@artvps.com.

Regards,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - Feb 28, 2020 06:12pm

I notice that you have your background set to ‘SketchUp Background’. I think using the ‘Lighting Environment’ setting should produce better results – this will render the background consistently with the lighting coming from the physical sky, which should include the warmer colour of evening sky light. The ‘SketchUp Background’ setting will render the exterior of your scene similarly to SketchUp’s viewport (and controlled by your SketchUp Style settings), which is not a physically realistic appearance. For example, if your SketchUp background is set to white, then it will appear white in Shaderlight too (modulo your exposure setting and any tinting on the windows).

While testing this today, I found that using SketchUp Background produced unexpectedly dark views of the exterior (even using a pure white, transparent material), similar to your original render in your other thread. There may be a bug in the current version of Shaderlight, or maybe I set my scene up incorrectly – I’ll need to investigate further. In any case, for photorealistic results, I would prefer the Lighting Environment setting (or a photographic backplate).

Note that the visibility of the sky lighting will depend on the brightness of your interior lighting. It looks like most of the lighting in your scene might be coming from the interior light sources, in which case the sky light will be fairly subtle.

If you would like us to take a closer look, you could send your model (or a Dropbox or similar link, if it’s large) to support@artvps.com.

Regards,
Shaderlight support

Thanks so much for your help!I switched background to Lighting Environment.
I was not getting any dark, I could see some detail.
So in this test..Auto Exposure is off.  And I have bumped manual exposure a couple of stops.  Still not bright enough.

Image Attachments
render_model_shot_720x405_Q5-04.jpg
Click thumbnail to see full-size image
blackdogsketch
Total Posts: 23

And here is the same resolution plus 4 stops…still not enough.
Detail in windows is almost getting blown out.  when I increase another stop…I’ll lose all detail. This is my main issue now.  Can I just decrease the Background Brightness?

Image Attachments
render_model_shot_720x405_Q5-05.jpg
Click thumbnail to see full-size image
blackdogsketch
Total Posts: 23

Exposure bumped to 5.  Background exposure down 2.5. The background exposure doesn’t seem to do much.

Image Attachments
render_model_shot_720x405_Q5-06.jpg
Click thumbnail to see full-size image
awaddington
Total Posts: 388

Hi,

A few quick thoughts.

First, you increased the exposure at the same time as reducing the background so the net change may not be significant. Try manually setting the exposure so the interior looks right, then reduce the background exposure (without changing the regular exposure) until you get the desired outcome.

Second, the background exposure changes the exposure for the background image, not the amount of exterior light. The physical sky isn’t as much of an image…I’m not sure what the expected behavior would be for that.

Third, I’ve always had better luck with the HDR lighting settings (Moofe, Preset, etc.) compared to physical sky; they are less harsh (and would likely be more receptive to your background exposure adjustments).

Fourth, and this one I risk being annoying stating again but sill relevant, the amount of light provided in the interior relative to the amount of exterior light will have a direct relation to the contrast of interior/exterior light. If you stand in a dark room lit by a window if your eyes are adjusted for the room, the view through the window is overexposed, and if they are adjusted for the view out the window, the interior will be underexposed. Our eyes adapt so quickly, we perceive balance between the interior/exterior.  To achieve the perception of balance between interior and exterior in a render, you need to reduce the gap between the interior/exterior light sources: significantly increase interior lighting or decrease exterior. I explored this a bit here: https://drive.google.com/file/d/0B32DwESKy7fbVTk1LUd2cnlQRTA/view (note the guide is outdated now, some of the limitations noted in the guide have been addressed in subsequent versions of Shaderlight but the theories still hold).

I hope this helps.

Cheers,

Andrew