Shaderlight

Shaderlight v7 - menu not showing up in SketchUp v19

 
emmaxx1
Total Posts: 1

Hi, I have installed a licensed SketchUp v19 and Shaderlight v7 on a users machine that runs Win 10 1809.
The Shaderlight menu is not showing up. If I go to the View menu - >Toolbars to try to select it, it doesn’t show up as an option in there either. I’ve tried repairing the Shaderlight installation but it still is not showing up in Sketchup. Please advise?

kfoojones
Total Posts: 284

Hi,

It’s possible that you’re running into SketchUp’s loading policy.

SketchUp has a system to help prevent malicious extensions from loading, but unfortunately Shaderlight is not compatible with the way that it has been implemented. In order for Shaderlight to load, either the protection has to be disabled, or Shaderlight has to be granted an exception. To do this, go to SketchUp’s Extension Manager (Window -> Extension Manager). In the Extension Manager window, click the ‘cog’ icon in the top-right to access the Settings and make sure that either ‘Unrestricted’ or ‘Approve Unidentified Extensions’ is selected. Confirm the Settings panel and click the ‘Disabled’ button next to Shaderlight to load it if necessary. (It will say ‘Enabled’ once it is loaded.)

‘Approve Unidentified Extensions’ leaves the protections in place, but requires you to manually approve Shaderlight each time you launch SketchUp. See https://help.sketchup.com/en/extensions-loading-policy for more information on this SketchUp system.

If your SketchUp’s loading policy was already set to ‘Unrestricted’ or Shaderlight still fails to load after making the changes above, please could you send us a screenshot or folder listing of the following location to help us decide what steps to take next:

On Windows: \ProgramData\SketchUp\SketchUp <VERSION>\SketchUp\Plugins
On macOS: /Library/Application Support/SketchUp <VERSION>/SketchUp/plugins

replacing <VERSION> with the version of SketchUp that you’re using (in your case 2019).

Regards,
Shaderlight support