Shaderlight

Interior scene with lights…but can’t get exterior light!

 
blackdogsketch
Total Posts: 23

Fairly complex model.  Interior scene with various lights.  All windows have skylight portal applied.  Have the interior balanced pretty well but can’t get any appreciable light to come thru the exterior windows.  Any help appreciated.

(In the attached render, the upper clerestory windows on both sides of the high space are exterior…as well at the large closer unit on on the right side.)

I’m using physical sky…boosting background brightness…global illumination…but it doesn’t seem to matter what parameters I change, nothing seems to work.

Image Attachments
render2.jpg
Click thumbnail to see full-size image
blackdogsketch
Total Posts: 23

OK, a couple of additional questions:  When placing Skylight Portals, the parameter “Dimming” is set to 100 by default.  What does this mean, that 100 is “Dimmed” all the way to allow no light? or 100 is 100% transparent?  It seems that once portals have been placed, it is not possible to go back to them later and edit the parameter, as you can do with lights.  But here’s the really weird thing…I try to set that “Dimming” parameter to 0 or 25 or 50…it seems like it’s going to work…but then for the very next placement it reverts back to 100.  When I go and check the first one I placed (using, say “50”) it is back to 100.  What the heck is going on?

kfoojones
Total Posts: 279

Hello,

There are a few things that can lead to this problem:

1) If the interior light intensities are set to unrealistically high levels, they can overpower the sky light and make it appear too dark (because the exposure has been set very low to compensate for the artificial lighting). Checking the exposure setting can give an indication if this might be the problem – a manual exposure below zero would suggest that the interior lighting is brighter than direct sunlight. (If you’re using automatic exposure, you could set it to manual and then adjust it up/down until it looks similar to your existing render to estimate what the automatic exposure was selecting.)

2) The material used on the window could block out much of the light from the outside. Depending on the SketchUp material colour and the Shaderlight material type and preset assigned, the material might be absorbing much more light than expected. Setting the SketchUp material colour to something lighter and / or less opaque might help.

3) The construction of the windows and the type of transparency you’re using in your window material can affect how much light passes through. You can either model windows by using two SketchUp faces (or even six, to enclose the edges, or twelve or more to fully model multiply-glazed units) to represent the thickness of the glass, or more simply using just a single SketchUp face. Fully modelling the glass will give the most realistic renders, properly rendering effects such as refraction and multiple reflections from each air / glass interface, but these effects are quite subtle and perfectly acceptable results can usually be obtained more quickly and simply by using the single face method – especially if the render isn’t a close-up of a window. When using the single face modelling method, it’s important to use the ‘thin glass’ Shaderlight material so that the renderer knows not to treat the single face as the ‘entrance’ to a solid block of glass – without an ‘exit’ face, rays will effectively travel an infinite distance before reaching the sky light source and will be completely absorbed unless you’re using a pure white SketchUp colour. The amount of refraction will also be far too high compared to passing through just a few millimetres of glass.

If none of the above can explain what’s happening with your model, please let us know and we’ll dig a little deeper.

For your second post, the ‘Dimmer’ setting specifies how much light is let through the portal – 100% means the full amount. We recommend always leaving the setting at 100% for the most physically accurate results, but it can be useful if you want to ‘cheat’ an HDR-like effect and prevent the bright skylight overpowering your internal lighting.

There is an unfortunate problem with the way SketchUp’s ‘WebDialogs’ (which is the mechanism that Shaderlight uses to display a user interface within SketchUp) handle text entry fields – if you type into them but then click in some other part of the SketchUp UI (perhaps to select another light portal), your typing is cancelled and the value gets reset. To avoid this, you need to ‘confirm’ your text entry by pressing the enter or tab key or clicking some other part of the Shaderlight light editor dialog. Although, as you describe the other light types behaving as you expect, it may be that something else is going wrong in your case – if so, please let us know and we will investigate further.

I hope that helps,
Shaderlight support

blackdogsketch
Total Posts: 23
kfoojones - Feb 26, 2020 06:43pm

Hello,

There are a few things that can lead to this problem:

1) If the interior light intensities are set to unrealistically high levels, they can overpower the sky light and make it appear too dark (because the exposure has been set very low to compensate for the artificial lighting). Checking the exposure setting can give an indication if this might be the problem – a manual exposure below zero would suggest that the interior lighting is brighter than direct sunlight. (If you’re using automatic exposure, you could set it to manual and then adjust it up/down until it looks similar to your existing render to estimate what the automatic exposure was selecting.)

2) The material used on the window could block out much of the light from the outside. Depending on the SketchUp material colour and the Shaderlight material type and preset assigned, the material might be absorbing much more light than expected. Setting the SketchUp material colour to something lighter and / or less opaque might help.

3) The construction of the windows and the type of transparency you’re using in your window material can affect how much light passes through. You can either model windows by using two SketchUp faces (or even six, to enclose the edges, or twelve or more to fully model multiply-glazed units) to represent the thickness of the glass, or more simply using just a single SketchUp face. Fully modelling the glass will give the most realistic renders, properly rendering effects such as refraction and multiple reflections from each air / glass interface, but these effects are quite subtle and perfectly acceptable results can usually be obtained more quickly and simply by using the single face method – especially if the render isn’t a close-up of a window. When using the single face modelling method, it’s important to use the ‘thin glass’ Shaderlight material so that the renderer knows not to treat the single face as the ‘entrance’ to a solid block of glass – without an ‘exit’ face, rays will effectively travel an infinite distance before reaching the sky light source and will be completely absorbed unless you’re using a pure white SketchUp colour. The amount of refraction will also be far too high compared to passing through just a few millimetres of glass.

If none of the above can explain what’s happening with your model, please let us know and we’ll dig a little deeper.

For your second post, the ‘Dimmer’ setting specifies how much light is let through the portal – 100% means the full amount. We recommend always leaving the setting at 100% for the most physically accurate results, but it can be useful if you want to ‘cheat’ an HDR-like effect and prevent the bright skylight overpowering your internal lighting.

There is an unfortunate problem with the way SketchUp’s ‘WebDialogs’ (which is the mechanism that Shaderlight uses to display a user interface within SketchUp) handle text entry fields – if you type into them but then click in some other part of the SketchUp UI (perhaps to select another light portal), your typing is cancelled and the value gets reset. To avoid this, you need to ‘confirm’ your text entry by pressing the enter or tab key or clicking some other part of the Shaderlight light editor dialog. Although, as you describe the other light types behaving as you expect, it may be that something else is going wrong in your case – if so, please let us know and we will investigate further.

I hope that helps,
Shaderlight support

Excellent descriptions…I really appreciate your clarity so much!  It’s often difficult to converse regarding technical matters like this; it’s easy to be misunderstood. ;-)

I usually start a render with no materials modified in Shaderlight.  That is, I take all sketchup materials “stock” and then at a later point, add material parameters as needed if “default” doesn’t seem to be adequate.  So I have a sketchup very clear glass…like 95% transparent, but I have not applied any Shaderlight material characteristics yet.  I’ll try both that and playing with manual exposure.  Thanks so much.

One further note…the instructions on Light Portals say to “place from the exterior side of the building”...but it seems that placing from the interior achieves the same thing.  I use the “SHIFT” key to reverse the light direction as needed.  Is this correct?
I have set the value for the light portal at something less than 100, just to try it, but hitting ENTER doesn’t “retain” the value…regardless of what I do, I cannot have it work at anything other than 100.  Also, selecting a previously-placed portal, and “editing” the value doesn’t work. It always reverts back to 100.

kfoojones
Total Posts: 279

Hi,

It could be that you’re looking at instructions for an earlier version of skylight portals in SketchUp. Where are you looking? Unfortunately our manual has become outdated (we no longer have access to the software that generated it), but we have a blog post describing the use of the newer version of skylight portals. With the newer portals, you can create them from either side, using the shift key as you describe to ensure that the point in the correct direction.

I have tried to reproduce the problem you’re seeing with the portal Dimmer setting, but it works as expected on a number of different systems here. Can you let us know which versions of SketchUp, Shaderlight and Windows / macOS you’re using, in case one of those things affects the behaviour?

Thank you,
Shaderlight support