Shaderlight

Pixel noise

 
jarom
Total Posts: 1

Hi,
I’m using Shaderlight for long time but i still have issue with a pixel noise. Rendering in the “phisical sky” and in the “Artifical light Only” as well.
See on the picture. Both of render was made in maximum quality. What unusual - shaderlight renders sometimes with such a noise, but somethime not. What can I do to fix ths issue?

And second question - in the message window I ‘ve information: “Hardware Acceleration: Disabled”. What should I do to enable hardwere acceleration?

jarom
Shaderlight for Sketchup: 2019 (7.0.0) for 64 bit Windows

Image Attachments
v-ray5_43_800x450.png
Click thumbnail to see full-size image
kfoojones
Total Posts: 279

Hi Jarom,

Noise like that that appears in a band is usually caused by an area light – the noise appears on surfaces that are close to the plane of the area light. Have you used an area light just below the ceiling to provide some ambient illumination? In general, we recommend avoiding that technique because it is not physically accurate, in addition to the noise issues it creates.

Usually, you should only use lights that represent real-world light sources in your scene, such as spot- or IES-lights in the downlights. Combined with using global illumination, that should create the correct balance of ambient illumination in the render. Sometimes it is desirable to create a more even lighting for artistic effect, which is where the area light comes in. In that case, if the maximum quality setting is unable to remove all of the noise, you can render at a much higher resolution and then shrink the image down to the desired size using an image editor – this will smooth out the noise a great deal. If there is still too much noise, you could consider rendering several times and then using an image editor to blend the individual renders together, which will average out the noise.

If the area light explanation is not applicable in your case, could you provide some more details about how your scene is set up? A screenshot from SketchUp showing the construction of your model and the position of any light sources could be helpful.

Another thing to consider, but probably unrelated to the noise issue, is that using Physical Sky for an interior render with no appreciable daylight will only make renders take longer for no reason – Shaderlight has to trace rays out to the sky to check whether it should record illumination from the sun/sky or if it should be blocked. If there are no windows to the outside then all the rays will be blocked and it will have been wasted work.

I’m afraid the ‘Hardware Acceleration: Disabled’ message is a red herring – Shaderlight doesn’t currently support hardware acceleration.

Regards,
Shaderlight support